Issues with Google Maps mobile SDKs in driver apps
Incident Report for Onfleet
Resolved
This incident has been resolved.
Posted Apr 23, 2020 - 15:54 PDT
Update
Confirmation from Google has been received:

Mitigation work is currently underway by our engineering team; roll-out of a potential fix is in-progress.
We will provide more information by Thursday, 2020-04-23 16:30 US/Pacific.
Posted Apr 23, 2020 - 15:29 PDT
Update
The Android app is now starting to behave better. We are seeing reduced numbers of Android crashes across the board. Please have your drivers clear app data in the settings and relaunch to hopefully restore a fully operational state. We will continue to monitor things closely.
Posted Apr 23, 2020 - 15:25 PDT
Update
Monitoring
The Onfleet iOS driver app appears to be returning to normal. We are definitely starting to see fewer crashes. We are waiting for Android to follow suit.
Posted Apr 23, 2020 - 15:00 PDT
Update
Google appears to have confirmed a roll-back of the code resulting in this issue: "Update: We have identified a possible root cause for the crash and are undoing the change."
Posted Apr 23, 2020 - 14:51 PDT
Update
Google is telling us that any communications will be handled via this bug instead: https://issuetracker.google.com/154855417
Posted Apr 23, 2020 - 14:27 PDT
Update
A unique look into this global issue can be found here: https://outage.report/google-maps
Posted Apr 23, 2020 - 14:14 PDT
Update
We have received no updates from Google yet but are continuing to monitor any and all communication channels with them. It looks like many global apps that initialize the Google Maps SDK (Uber, Lyft, Airbnb) on some or all mobile operating systems are currently experiencing the same crashing behavior. Unfortunately, the only readily available fix is for Google to resolve this on their end. Thank you for your patience.
Posted Apr 23, 2020 - 14:07 PDT
Update
Google enterprise phone support has confirmed that they are all hands on deck at this time attempting to resolve this global outage affecting thousands of their customers.
Posted Apr 23, 2020 - 13:31 PDT
Update
For iOS users, we have established that it's the map view that triggers the crash. We highly recommend that drivers do not load it while Google works to resolve this issue so that the app can be used normally. Unfortunately, we have not yet found a similar temporary solution for Android users.
Posted Apr 23, 2020 - 13:25 PDT
Update
We are waiting for any news from Google and looking for potential ways to avoid map initialization to see if the app can be used without crashing. Unfortunately, this is a very serious global issue on Google's part that may be hard for us to make stop via a hotfix but we are working on any and all options.
Posted Apr 23, 2020 - 13:17 PDT
Update
For the technically inclined, here's the bug report with Google: https://issuetracker.google.com/issues/154820090
Posted Apr 23, 2020 - 13:15 PDT
Identified
It appears that Google has messed something up on their end which is resulting in crashes for both our Android and iOS driver apps. We are quickly working on a hotfix however this does appear to be a global issue. We currently have a critical priority ticket open with their enterprise support team.
Posted Apr 23, 2020 - 13:14 PDT
This incident affected: iOS and Android.