USA SMS Delivery Interruption

Incident Report for Onfleet

Resolved

The incident has been resolved and SMS functionality is fully restored.

Please note that SMS messages may show a different phone number until we have resolved the issue with our primary provider.
Posted Jul 22, 2026 - 13:47 PDT

Update

Update -- SMS Delivery for US Customers

The majority of affected SMS notifications have been restored. Early this morning, we rerouted traffic through a backup telephony provider after a carrier-side interruption affected delivery on one of our primary provider's numbers.

A small number of residual delivery failures remain, affecting a limited subset of notifications. A fix is planned and we expect these to be resolved today. We'll update this page when fully resolved.

We apologize for the disruption and appreciate your patience.
Posted Jul 22, 2026 - 10:44 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2026 - 05:33 PDT

Investigating

A subset of our USA customers may be impacted by an SMS delivery fault. We are working with providers to resolve this issue now.
Posted Jul 21, 2026 - 22:05 PDT
This incident affected: Outgoing Text Gateway and Proxy.