Task selection slowdown

Incident Report for Onfleet

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 12:06 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 11:57 PDT

Identified

An issue has been detected in the release this morning that resulted in degraded performance with task selection. The team is rolling back this release and monitoring the update.
Posted Apr 07, 2026 - 11:42 PDT
This incident affected: Dashboard.