Onfleet unavailable
Incident Report for Onfleet
Postmortem

At approximately 9:15 AM Pacific Onfleet's core services reported degraded performance. After investigation, Onfleet Engineering discovered a temporary database exhausted available memory, resulting in an unhandled error that further reduced system availability. Onfleet restored normal service by freeing memory resources and resolving the unhandled error. Availability was restored to all users by 11:30 AM Pacific. To prevent this from happening in the future, Onfleet has introduced improved monitoring and initiated a review to ensure no additional resources are susceptible.

Posted Aug 30, 2019 - 15:41 PDT

Resolved
This incident has now been resolved. All services are confirmed to be operating normally.

We will follow up with a more detailed post-mortem soon.
Posted Aug 30, 2019 - 13:04 PDT
Monitoring
We have now deployed a short-term patch and are working on a permanent solution. We will continue to monitor all systems closely and update this channel.
Posted Aug 30, 2019 - 11:26 PDT
Investigating
We are currently investigating this issue
Posted Aug 30, 2019 - 09:57 PDT
This incident affected: Dashboard and API.