Elevated Response Times

Incident Report for Onfleet

Resolved

System performance has improved significantly and most if not all functions should be operating without excessive delay.

Further adjustments to database queries are in progress to avoid this issue in the future.
Posted May 05, 2025 - 13:25 PDT

Identified

The team has identified some changes to database queries to alleviate this issue, and will be publishing these changes as soon as possible.
Posted May 05, 2025 - 11:23 PDT

Investigating

Monitoring indicates increased response times overall. Our infrastructure teams are investigating the issue.
Posted May 05, 2025 - 09:54 PDT
This incident affected: Dashboard and API.